🔴 Important Notice: Email Service Temporarily Unavailable

Incident Report for Kroolo

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 05:43 UTC

Identified

The issue has been identified, and our team is actively working with AWS to resolve it.
Posted Jun 30, 2025 - 13:54 UTC

Update

We are continuing to investigate this issue.
Posted Jun 30, 2025 - 13:51 UTC

Investigating

We are currently experiencing an issue with our email delivery system.

Due to a temporary restriction applied by our email provider (Amazon SES), we are unable to send verification or password reset emails at this time.

❌ Impacted Features:

- New user signups (OTP email not delivered)
- Forgot password flow (reset email not sent)

We are actively working with AWS to resolve this issue as a priority. We sincerely apologize for the inconvenience and appreciate your patience.

✅ We’ll update this message as soon as the issue is resolved.

If you need immediate help or access to your account, please contact our support team at help@kroolo.com.

Thank you,
Kroolo Team
Posted Jun 30, 2025 - 13:50 UTC